macOS X .iso to Bootable USB

--

This is a quick cheat sheat to make a bootable USB drive from an .iso file using the terminal in macOS X.

Elevate your privelegs to root: (be careful with root — you have been warned)

sudo -s

Convert the .iso to .dmg:

hdiutil convert -format UDRW -o ubuntu-server-24.04.img ~/Downloads/ubuntu-24.04-live-server-amd64.iso

Without your USB drive plugged in, see what drives you have.

diskutil list

Make note of the /dev/disk* listing.

Plug in your USB drive.

diskutil list

Note what /dev/disk* was added. You’ll use this in the next dd command.

Write the .dmg file to the USB device. (note: we add an “r” to the device name: /dev/disk6 becomes /dev/rdisk6)

dd if=./ubuntu-server-24.04.img.dmg of=/dev/rdisk6 bs=1m  

When that finishes, you should have a bootable USB drive. Eject and enjoy!

--

--

Anders Brownworth

Radius & MIT DCI — formerly Federal Reserve, USDC @ Circle.com, Bandwidth.com. MIT / Podcaster / Runner / Helicopter Pilot https://andersbrownworth.com